]> Pileus Git - ~andy/sunrise/blob - dev-cpp/opensaml/opensaml-1.1.4.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / dev-cpp / opensaml / opensaml-1.1.4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils autotools
6
7 DESCRIPTION="Open Source Security Assertion Markup Language implementation"
8 HOMEPAGE="http://www.opensaml.org/"
9 SRC_URI="http://shibboleth.internet2.edu/downloads/${PN}/cpp/${PV}/${P}.tar.gz"
10
11 LICENSE="Apache-2.0"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 DEPEND="dev-libs/openssl
17         net-misc/curl
18         dev-libs/log4shib
19         dev-libs/xerces-c
20         >=dev-libs/xml-security-c-1.3.0"
21 RDEPEND=${DEPEND}
22
23 src_unpack() {
24         unpack ${A}
25         cd "${S}"
26
27         # make documentation location Gentoo like
28         epatch "${FILESDIR}"/opensaml_doc.diff
29         eautoreconf
30 }
31
32 src_install() {
33         emake DESTDIR="${D}" install || die "install failed"
34
35         dodoc doc/{NEWS,NOTICE,README}.txt || die
36 }