]> Pileus Git - ~andy/sunrise/blob - dev-cpp/libiqxmlrpc/libiqxmlrpc-0.8.9.ebuild
dev-db/cppdb: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / dev-cpp / libiqxmlrpc / libiqxmlrpc-0.8.9.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit autotools eutils
8
9 DESCRIPTION="An object-oriented library which represents simple XML-RPC solution for client and server side."
10 HOMEPAGE="http://libiqxmlrpc.wikidot.com/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
12
13 LICENSE="LGPL-2"
14 SLOT="0"
15 KEYWORDS="~x86 ~amd64"
16 IUSE="doc debug"
17
18 RDEPEND="=dev-cpp/libxmlpp-1*
19         dev-libs/libxml2
20         >=dev-libs/boost-1.35.0-r5
21         dev-libs/openssl"
22 DEPEND="${RDEPEND}
23         doc? ( app-doc/doxygen )"
24
25 src_prepare() {
26         epatch "${FILESDIR}/${PV}-boost_test_framework_detection.patch"
27         AT_M4DIR="m4"
28         eautoreconf
29 }
30
31 src_configure() {
32         econf \
33                 $(use_enable doc docs) \
34                 $(use_enable debug) \
35                 --with-boost-unit-test-framework
36 }
37
38 src_compile() {
39         # otherwise the package ignores them
40         emake CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
41 }
42
43 src_install() {
44         # We install the docs manually, because: i) sandbox violations ii) wrong location
45         emake DESTDIR="${D}" MKDOC=no install || die "emake install failed"
46         dodoc ChangeLog README NEWS
47         use doc && dohtml doc/libiqxmlrpc.html/*
48 }