]> Pileus Git - ~andy/sunrise/blob - dev-cpp/libiqxmlrpc/libiqxmlrpc-0.7.3a.ebuild
dev-cpp/libiqxmlrpc: Version bump.
[~andy/sunrise] / dev-cpp / libiqxmlrpc / libiqxmlrpc-0.7.3a.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="Libiqxmlrpc is an object-oriented library, which represents simple XML-RPC solution both for client and server sides."
8 HOMEPAGE="http://libiqxmlrpc.sourceforge.net"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="LGPL-2"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE="doc debug"
15
16 RDEPEND="=dev-cpp/libxmlpp-1*
17                 dev-libs/libxml2
18                 dev-libs/boost
19                 dev-libs/openssl"
20 DEPEND="${RDEPEND}
21                 doc? ( app-doc/doxygen )"
22
23 pgk_setup() {
24         if ! built_with_use dev-libs/boost threads ; then
25                 eerror "dev-libs/boost has to be compiled with 'threads' USE-flag enabled."
26                 die "Needed USE-flag for dev-libs/boost not found."
27         fi
28 }
29
30 src_unpack() {
31         unpack ${A}
32         cd "${S}"
33         epatch "${FILESDIR}/${PV}-doc_manual_install.patch"
34 }
35
36 src_compile() {
37         econf \
38                 $(use_enable doc docs) \
39                 $(use_enable debug) \
40                 --with-boost-thread=boost_thread-mt \
41                 --with-boost--program-options=boost_program_options-mt \
42                 --with-boost-unit-test-framework=boost_unit_test_framework-mt \
43                 || die "econf failed"
44         emake CXXFLAGS="${CXXFLAGS}" || die "emake failed"
45 }
46
47 src_install() {
48         emake DESTDIR="${D}" install || die "emake install failed"
49         dodoc ChangeLog README NEWS TODO
50         if use doc; then
51                 dohtml doc/libiqxmlrpc.html/*
52         fi
53 }
54
55 src_test() {
56         einfo "This can take some time due to stress tests"
57         cd "${S}/tests"
58         make check
59         ./regression.sh
60 }