]> Pileus Git - ~andy/sunrise/blob - dev-cpp/libcwd/libcwd-0.99.47.ebuild
dev-cpp/ETL: Version bump
[~andy/sunrise] / dev-cpp / libcwd / libcwd-0.99.47.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="A library to support C++ developers with debugging their applications"
8 HOMEPAGE="http://libcwd.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="QPL"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="debug doc examples pch"
15
16 DEPEND="doc? ( app-doc/doxygen )"
17 RDEPEND=""
18
19 src_unpack() {
20         unpack ${A}
21         cd "${S}"
22
23         sed -i \
24                 -e 's/-O3//' \
25                 configure || die "sed failed"
26
27         # Clean-out possibly old docs
28         rm -f  documentation/doxygen.config
29         rm -rf documentation/html/*
30 }
31
32 src_compile() {
33         econf \
34                 $(use_enable pch) \
35                 $(use_enable debug) \
36                 || die "econf failed"
37         emake || die "emake failed"
38
39         if use doc; then
40                 cd documentation
41                 doxygen doxygen.config
42         fi
43 }
44
45 src_install() {
46         emake DESTDIR="${D}" install || die "emake install failed"
47
48         dodoc README* NEWS
49
50         if use doc; then
51                 dohtml -r documentation/reference-manual/*
52                 insinto /usr/share/doc/${PF}
53                 doins -r documentation/tutorial
54         fi
55
56         if use examples; then
57                 insinto /usr/share/doc/${PF}
58                 doins -r example-project
59         fi
60 }