]> Pileus Git - ~andy/sunrise/blob - dev-cpp/libcutl/libcutl-1.6.2.ebuild
dev-libs/libserial: Adding ~amd64 keyword
[~andy/sunrise] / dev-cpp / libcutl / libcutl-1.6.2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit autotools-utils versionator
8
9 DESCRIPTION="Library of C++ utilities -- meta-programming tests, smart pointers, containers"
10 HOMEPAGE="http://codesynthesis.com/projects/libcutl/"
11 SRC_URI="http://codesynthesis.com/download/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="static-libs"
17
18 RDEPEND="dev-libs/boost"
19 DEPEND="${RDEPEND}"
20
21 src_configure() {
22         local myeconfargs=(
23                 --with-external-boost
24                 --docdir=/tmp/dropme
25         )
26
27         autotools-utils_src_configure
28 }
29
30 src_install() {
31         autotools-utils_src_install
32
33         rm -r "${D}"/tmp/dropme || die
34 }