]> Pileus Git - ~andy/sunrise/blob - dev-cpp/hiberlite/hiberlite-0.6.ebuild
games-board/qbriscola: Fix qt deps, EAPI bump, add ~amd64 keyword
[~andy/sunrise] / dev-cpp / hiberlite / hiberlite-0.6.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils
8
9 DESCRIPTION="C++ object-relational mapping API inspired by Boost.Serialization"
10 HOMEPAGE="http://code.google.com/p/hiberlite"
11 SRC_URI="http://${PN}.googlecode.com/files/${P}.zip"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE=""
17
18 RDEPEND="dev-db/sqlite:3"
19 DEPEND="${RDEPEND}
20         app-arch/unzip"
21
22 src_prepare() {
23         epatch "${FILESDIR}"/${P}-gcc46.patch
24 }
25
26 src_install() {
27         emake INSTALL_PREFIX="${D}/usr" install
28 }