]> Pileus Git - ~andy/sunrise/blob - dev-cpp/gtkmm-utils/gtkmm-utils-0.3.2.ebuild
65c2bfc213bbe72129585121471dc23687fbc95f
[~andy/sunrise] / dev-cpp / gtkmm-utils / gtkmm-utils-0.3.2.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit versionator
6
7 MY_PVM=$(get_version_component_range 1-2)
8
9 DESCRIPTION="Utility functions, classes and widgets written on top of gtkmm and glibmm."
10 HOMEPAGE="http://live.gnome.org/gtkmm_utils"
11 SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${MY_PVM}/${P}.tar.bz2"
12 LICENSE="LGPL-2"
13
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE="doc"
17
18 RDEPEND=">=dev-cpp/gtkmm-2.10.0"
19 DEPEND="doc? ( app-doc/doxygen )
20         dev-util/pkgconfig
21         ${RDEPEND}"
22
23 src_compile() {
24         econf $(use_enable doc documentation)
25         emake || die "emake failed"
26 }
27
28 src_install() {
29         emake DESTDIR="${D}" install || die "Install failed"
30 }