]> Pileus Git - ~andy/sunrise/blob - dev-cpp/ETL/ETL-502.ebuild
media-gfx/synfig: Fix invalid version and invalid SRC_URI
[~andy/sunrise] / dev-cpp / ETL / ETL-502.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4 DESCRIPTION="VoriaETL is a multiplatform class and template library designed to
5 complement and supplement the C++ STL."
6 HOMEPAGE="http://www.synfig.com/"
7 SRC_URI="mirror://gentoo/$PF.tar.bz2"
8
9 LICENSE="GPL-2"
10 SLOT="0"
11 KEYWORDS="~amd64 ~x86"
12 IUSE="doc"
13 DEPEND="doc? ( app-doc/doxygen )"
14
15 WANT_AUTOCONF="2.5"
16 WANT_AUTOMAKE="1.6"
17 inherit autotools
18
19 src_compile() {
20         ./bootstrap || die 'Bootstrap failed.'
21         econf || die 'Configure failed.'
22         emake || die 'Make failed.'
23         if use doc; then emake docs || die '"Make docs" failed.'; fi
24 }
25
26 src_install() {
27         emake DESTDIR="$D" install || die 'Install failed!'
28         if use doc; then
29                 insinto "/usr/share/doc/$PF"
30                 dohtml doc/html/*
31         fi
32 }