]> Pileus Git - ~andy/sunrise/blob - app-vim/clewn/clewn-1.9.ebuild
app-vim/clewn: Fix RDEPEND, cosmetics
[~andy/sunrise] / app-vim / clewn / clewn-1.9.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils vim-doc
6
7 DESCRIPTION="A small utility which allows debugging from within vim"
8 HOMEPAGE="http://clewn.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 DEPEND=">=app-editors/gvim-7.0
17         sys-libs/readline"
18 RDEPEND="${DEPEND}"
19 S="${WORKDIR}/${PN}"
20
21 pkg_setup() {
22         if ! built_with_use app-editors/gvim netbeans ; then
23                 eerror "Please (re)emerge gvim with netbeans USE flag on before "
24                 eerror "emerging clewn"
25                 die "please (re)emerge app-editors/gvim with USE='netbeans'"
26         fi
27 }
28
29 src_install() {
30         dodoc README.txt CHANGELOG
31         dobin clewn
32         dodir /usr/share/vim/vimfiles
33         tar -xzf "${S}/runtime/clewn_runtime.tgz" -C "${D}/usr/share/vim/vimfiles"
34 }
35
36 pkg_postinst() {
37         update_vim_helptags
38 }