]> Pileus Git - ~andy/sunrise/blob - app-text/unac/unac-1.8.0.ebuild
986da3c1493a691741bde8d9c1b08ef6c6c54bcf
[~andy/sunrise] / app-text / unac / unac-1.8.0.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit autotools
6
7 DESCRIPTION="unac is a C library and a command line tool that removes accents from characters."
8 HOMEPAGE="http://www.senga.org/"
9 SRC_URI="mirror://debian/pool/main/u/unac/${P/-/_}.orig.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 RDEPEND="virtual/libiconv"
17 DEPEND="${RDEPEND}
18         dev-lang/perl"
19
20 S="${WORKDIR}/${P}.orig"
21
22 src_unpack() {
23         unpack ${A}
24         cd "${S}"
25         # otherwise automake will fail
26         touch config.rpath
27         eautoreconf
28 }
29
30 src_install() {
31         emake DESTDIR="${D}" install || die "emake install failed"
32         dodoc AUTHORS ChangeLog NEWS README THANKS
33         doman unaccent.1 unac.3
34 }
35
36 pkg_postinst() {
37         einfo
38         einfo "Examples of using unaccent from the command line:"
39         einfo "unaccent utf8 été"
40         einfo "echo -e '\\\\0303\\\\0251t\\\\0303\\\\0251' | unaccent utf8"
41         einfo "unaccent ISO-8859-1 < myfile > myfile.unaccent"
42         einfo
43         einfo "man unaccent and man unac for more information."
44 }