]> Pileus Git - ~andy/sunrise/blob - app-text/referencer/referencer-1.1.6-r2.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / app-text / referencer / referencer-1.1.6-r2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit fdo-mime
8
9 DESCRIPTION="Gnome application to organise documents or references, and to generate BibTeX bibliography files"
10 HOMEPAGE="http://icculus.org/referencer/"
11 SRC_URI="http://icculus.org/${PN}/downloads/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND=">=app-text/poppler-0.12.3-r3
19         >=dev-cpp/gtkmm-2.8
20         >=dev-cpp/libgnomeuimm-2.14.0
21         >=dev-cpp/gnome-vfsmm-2.14.0
22         >=dev-cpp/libglademm-2.6.0
23         >=dev-cpp/gconfmm-2.14.0
24         dev-libs/boost
25         dev-lang/python"
26
27 DEPEND="${RDEPEND}
28         >=app-text/gnome-doc-utils-0.3.2
29         dev-util/pkgconfig
30         >=dev-lang/perl-5.8.1
31         dev-perl/libxml-perl
32         dev-util/intltool
33         app-text/rarian"
34
35 src_configure() {
36         econf --disable-update-mime-database --enable-python
37 }
38
39 src_install() {
40         emake install DESTDIR="${D}" || die "emake failed"
41         dodoc AUTHORS ChangeLog NEWS README TODO || die
42 }
43
44 pkg_postinst() {
45         fdo-mime_mime_database_update
46 }
47
48 pkg_postrm() {
49         fdo-mime_mime_database_update
50 }