]> Pileus Git - ~andy/sunrise/blob - app-text/pdfedit/pdfedit-0.4.3.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / app-text / pdfedit / pdfedit-0.4.3.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit qt3
8
9 DESCRIPTION="Editor for manipulating PDF documents. GUI and commandline interface."
10 HOMEPAGE="http://pdfedit.petricek.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
12
13 SLOT="0"
14 LICENSE="GPL-2"
15 KEYWORDS="~amd64 ~x86"
16
17 IUSE="doc"
18 RDEPEND="=x11-libs/qt-3*
19         media-libs/t1lib"
20 DEPEND="${RDEPEND}
21         dev-libs/boost
22         doc? ( app-doc/doxygen )"
23
24 src_configure(){
25         # for C{,XX}_EXTRA read README and bug #277723
26         # Disable parallel make detection as we pass required -j with emake
27         # ARCH is set to avoid pollution of CFLAGS with arch value...
28         econf \
29                 --docdir=/usr/share/doc/${PF}/ \
30                 --with-parallel-make=off \
31                 $(use_enable doc doxygen-doc) \
32                 $(use_enable doc advanced-doc) \
33                 ARCH="" \
34                 C_EXTRA="-fmessage-length=0 -D_FORTIFY_SOURCE=2 -fno-strict-aliasing ${CFLAGS}" \
35                 CXX_EXTRA="-fmessage-length=0 -D_FORTIFY_SOURCE=2 -fno-strict-aliasing -fexceptions ${CXXFLAGS}"
36 }
37
38 src_install() {
39         emake INSTALL_ROOT="${D}" install || die "emake install failed"
40         rm "${D}"/usr/share/doc/${PF}/{LICENSE.GPL,README.cygwin}
41 }