]> Pileus Git - ~andy/sunrise/blob - app-text/pdfedit/pdfedit-0.4.1.ebuild
1bc3fb8d9de3e0051c9aa911dab0321ad1fa0004
[~andy/sunrise] / app-text / pdfedit / pdfedit-0.4.1.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit qt3
6
7 DESCRIPTION="Editor for manipulating PDF documents. GUI and commandline interface."
8 HOMEPAGE="http://pdfedit.petricek.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 SLOT="0"
12 LICENSE="GPL-2"
13 KEYWORDS="~amd64 ~x86"
14
15 IUSE="doc"
16 RDEPEND="=x11-libs/qt-3*
17         media-libs/t1lib"
18 DEPEND="${RDEPEND}
19         dev-libs/boost
20         doc? ( app-doc/doxygen )"
21
22 src_compile(){
23         econf $(use_enable doc doxygen-doc) $(use_enable doc advanced-doc)
24         emake || die "emake failed"
25 }
26
27 src_install() {
28         emake INSTALL_ROOT="${D}" install || die "emake install failed"
29 }