]> Pileus Git - ~andy/sunrise/blob - app-text/pdfedit/pdfedit-0.2.5.ebuild
app-text/pdfedit 0.2.5 version bump
[~andy/sunrise] / app-text / pdfedit / pdfedit-0.2.5.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils qt3
6
7 DESCRIPTION="Editor for manipulating PDF documents. GUI and commandline interface."
8 HOMEPAGE="http://pdfedit.petricek.net"
9 SRC_URI="http://downloads.sourceforge.net/pdfedit/${P}.tar.gz"
10
11 SLOT="0"
12 LICENSE="GPL-2"
13 KEYWORDS="~amd64 ~x86"
14
15 IUSE=""
16 RDEPEND="$(qt_min_version 3.3)"
17 DEPEND="${RDEPEND}
18         dev-libs/boost"
19
20 src_unpack(){
21         unpack ${A}
22         cd "${S}"
23         epatch "${FILESDIR}/${PN}-0.2.3-build-fix.patch"
24 }
25
26 src_compile(){
27         econf || die "econf failed"
28         emake src || die "emake failed"
29 }
30
31 src_install() {
32         emake INSTALL_ROOT="${D}" install || die "emake install failed"
33 }