]> Pileus Git - ~andy/sunrise/blob - app-text/ocropus-svn/ocropus-svn-9999.ebuild
8f1e1f451161f4a338623c5048f862ecc9787960
[~andy/sunrise] / app-text / ocropus-svn / ocropus-svn-9999.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit subversion
6
7 DESCRIPTION="OCRopus is a state-of-the-art document analysis and OCR system."
8 HOMEPAGE="http://code.google.com/p/ocropus/"
9
10 ESVN_REPO_URI="http://ocropus.googlecode.com/svn/trunk"
11
12 LICENSE="Apache-2.0"
13 SLOT="0"
14 KEYWORDS=""
15 IUSE=""
16
17 RDEPEND=">=app-text/tesseract-1.04b
18         app-text/aspell
19         media-libs/tiff
20         media-libs/libpng
21         media-libs/jpeg"
22 DEPEND="${RDEPEND}
23         dev-util/jam"
24
25 src_compile() {
26         econf --with-tesseract=/usr || die "econf failed"
27         emake || die "emake failed"
28 }
29
30 src_test() {
31         cd "${S}/testing"
32         ./test-compile || die "Tests failed to compile"
33         ./test-run || die "At least one test failed"
34 }
35
36 src_install() {
37         dobin ocropus-cmd/ocropus
38         dodoc README DIRS
39 }