]> Pileus Git - ~andy/sunrise/blob - app-text/epdfview/epdfview-0.1.5.ebuild
x11-themes/gtk-engines-murrine: Remove, in portage
[~andy/sunrise] / app-text / epdfview / epdfview-0.1.5.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="Lightweight PDF viewer"
8 HOMEPAGE="http://www.emma-soft.com/projects/epdfview/"
9 SRC_URI="http://www.emma-soft.com/projects/epdfview/chrome/site/releases/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="cups nls test"
15
16 COMMON_DEPEND=">=x11-libs/gtk+-2.6
17         >=app-text/poppler-bindings-0.5.0
18         cups? ( >=net-print/cups-1.1 )"
19
20 DEPEND="${COMMON_DEPEND}
21         >=dev-util/pkgconfig-0.9
22         test? ( dev-util/cppunit )
23         nls? ( sys-devel/gettext )"
24
25 RDEPEND="${COMMON_DEPEND}
26         nls? ( virtual/libintl )"
27
28 pkg_setup() {
29         if ! built_with_use app-text/poppler-bindings gtk; then
30                 eerror "Please re-emerge app-text/poppler-binding with the gtk USE flag set."
31                 die "poppler-bindings needs gtk flag set."
32         fi
33 }
34
35 src_compile() {
36         econf \
37                 $(use_enable cups) \
38                 $(use_with nls) \
39                 || die "econf failed"
40         emake || die "emake failed"
41 }
42
43 src_install() {
44         emake DESTDIR="${D}" install || die "emake install failed"
45         dodoc AUTHORS NEWS README THANKS
46 }