]> Pileus Git - ~andy/sunrise/blob - app-text/docfrac/docfrac-3.1.5.ebuild
sys-apps/uam: Update SRC_URI.
[~andy/sunrise] / app-text / docfrac / docfrac-3.1.5.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit toolchain-funcs
6
7 DESCRIPTION="rtf/html/text conversion utility"
8 HOMEPAGE="http://docfrac.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.src.tar.gz"
10
11 LICENSE="LGPL-2.1"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND=""
17 RDEPEND=""
18
19 src_unpack() {
20         unpack ${A}
21         cd "${S}"
22
23         sed -i \
24                 -e "/CPPFLAGS=/s:-.*::" \
25                 -e "s:ar -:$(tc-getAR) -:" \
26                 -e "s:g++ -:$(tc-getCXX) -:g" Makefile \
27                 || die "sed failed in Makefile"
28 }
29
30 src_compile() {
31         make docfrac || die "emake failed"
32 }
33
34 src_test() {
35         make testhtml testtxt test || die "some tests failed"
36 }
37
38 src_install() {
39         # manual install because Makefile doesn't respect DESTDIR
40         dobin docfrac
41         doman doc/docfrac.1
42 }