]> Pileus Git - ~andy/sunrise/blob - app-text/docfrac/docfrac-3.1.5.ebuild
app-admin/noobjuice-viewer: Fix qt deps, EAPI bump
[~andy/sunrise] / app-text / docfrac / docfrac-3.1.5.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils toolchain-funcs
8
9 DESCRIPTION="rtf/html/text conversion utility"
10 HOMEPAGE="http://docfrac.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.src.tar.gz"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 src_prepare() {
19         sed -i \
20                 -e "/CPPFLAGS=/s:-.*::" \
21                 -e "s:ar -:$(tc-getAR) -:" \
22                 -e "s:g++ -:$(tc-getCXX) -:g" \
23                 Makefile || die "sed failed in Makefile"
24
25         epatch "${FILESDIR}"/${PV}-gcc46.patch
26 }
27
28 src_compile() {
29         emake ${PN}
30 }
31
32 src_install() {
33         # manual install because Makefile doesn't respect DESTDIR
34         dobin ${PN}
35         doman doc/${PN}.1
36 }