]> Pileus Git - ~andy/sunrise/blob - app-text/docfrac/docfrac-3.1.5.ebuild
90a53ac2c79bc9467e28329f41ca1d7939196c44
[~andy/sunrise] / app-text / docfrac / docfrac-3.1.5.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils toolchain-funcs
8
9 DESCRIPTION="rtf/html/text conversion utility"
10 HOMEPAGE="http://docfrac.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.src.tar.gz"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND=""
19
20 src_prepare() {
21         sed -i \
22                 -e "/CPPFLAGS=/s:-.*::" \
23                 -e "s:ar -:$(tc-getAR) -:" \
24                 -e "s:g++ -:$(tc-getCXX) -:g" \
25                 Makefile || die "sed failed in Makefile"
26
27         epatch "${FILESDIR}"/${PV}-gcc46.patch
28 }
29
30 src_compile() {
31         emake ${PN}
32 }
33
34 src_install() {
35         # manual install because Makefile doesn't respect DESTDIR
36         dobin ${PN}
37         doman doc/${PN}.1
38 }