]> Pileus Git - ~andy/sunrise/blob - app-text/docbook2odf/docbook2odf-0.244.ebuild
x11-libs/libqglviewer: Properly fix qt deps
[~andy/sunrise] / app-text / docbook2odf / docbook2odf-0.244.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="A toolkit that automaticaly converts DocBook to OASIS OpenDocument"
8 HOMEPAGE="http://open.comsultia.com/docbook2odf/"
9 SRC_URI="http://open.comsultia.com/${PN}/dwn/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="examples"
15
16 RDEPEND="
17         >=app-text/docbook2odf-xsl-stylesheets-0.244
18         >=dev-lang/perl-5.8
19         || ( >=dev-perl/XML-Sablot-1.01
20                  >=dev-libs/libxslt-1.1 )
21         >=media-gfx/imagemagick-6.2
22         || ( >=dev-perl/Archive-Zip-1.1
23                  >=app-arch/zip-2.3 )
24 "
25
26 src_install() {
27         if use examples; then
28                 docinto examples
29                 dodoc examples/* || die "Could not install examples"
30         fi
31
32         domenu bindings/desktop/*.desktop || die
33
34         doman docs/docbook2odf.1 || die
35
36         dobin utils/docbook2odf \
37                 || die "Could not install the executable"
38 }