]> Pileus Git - ~andy/sunrise/blob - app-shells/zsh-completions/zsh-completions-0.7.0.ebuild
app-dicts/words-bin: Adding ~amd64 keyword
[~andy/sunrise] / app-shells / zsh-completions / zsh-completions-0.7.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit vcs-snapshot
8 DESCRIPTION="Additional completion definitions for Zsh"
9 HOMEPAGE="https://github.com/zsh-users/zsh-completions"
10 SRC_URI="https://github.com/zsh-users/${PN}/tarball/${PV} -> ${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16 RDEPEND="app-shells/zsh
17         app-shells/zsh-completion"
18
19 src_prepare() {
20         rm src/_{baselayout,eselect,gcc-config,genlop,gentoo_packages,gentoolkit,layman,portage,portage_utils,yaourt} || die
21 }
22
23 src_install() {
24         insinto /usr/share/zsh/site-functions/
25         doins src/*
26 }
27
28 pkg_postinst() {
29         elog
30         elog "If you happen to compile your functions, you may need to delete"
31         elog "~/.zcompdump{,.zwc} and recompile to make zsh-completion available"
32         elog "to your shell."
33         elog
34 }