]> Pileus Git - ~andy/sunrise/blob - app-portage/portage-hooks/portage-hooks-0.1.ebuild
sci-libs/grits: Version bump for grits-0.8.1
[~andy/sunrise] / app-portage / portage-hooks / portage-hooks-0.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="System of hooks for portage"
6 HOMEPAGE="http://www.salug.it/~sydro/progetti/"
7
8 LICENSE="GPL-2"
9 SLOT="0"
10 KEYWORDS="~x86"
11 IUSE=""
12
13 src_install() {
14         insinto /etc/portage
15         doins "${FILESDIR}/portage-hooks" || die "Error copy portage-hooks into /etc/portage directory"
16 }
17
18 pkg_postinst() {
19         elog "You must create a directory in /etc/portage/hooks with ebuild phase name."
20         elog "Es. EBUILD_PHASE=preinst  The directory should be /etc/portage/hooks/preinst.d"
21         elog "In each directory there are any numbered scripts:  10example 20example"
22         elog
23         elog  "If you would use portage-hooks system you need to append the"
24         elog  "following statement to your"
25         elog  "/etc/portage/bashrc file:"
26         elog
27         elog  "source /etc/portage/portage-hooks"
28         elog
29 }