]> Pileus Git - ~andy/sunrise/blob - app-portage/etcproposals/etcproposals-1.1.ebuild
cc858535255e35f01e859b618d0fc1dff558f579
[~andy/sunrise] / app-portage / etcproposals / etcproposals-1.1.ebuild
1 # Copyright 2007-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit distutils
6
7 DESCRIPTION="a set of tools for updating gentoo config files"
8 HOMEPAGE="http://developer.berlios.de/projects/etc-proposals/"
9 SRC_URI="mirror://berlios/etc-proposals/${P}.tar.gz"
10
11 IUSE="gtk"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15
16 DEPEND="gtk? ( >=dev-python/pygtk-2.10 )"
17 RDEPEND="${DEPEND}"
18
19 src_install(){
20         distutils_src_install
21         dodir /usr/sbin
22         dosbin "${D}"/usr/bin/etc-proposals
23         rm -rf "${D}"/usr/{bin,share}
24 }
25
26 pkg_postinst() {
27         einfo "The configuration file has been installed to /etc/etc-proposals.conf"
28         ewarn "A full backup of /etc and other files managed by CONFIG_PROTECT"
29         ewarn "is highly advised before testing this tool!"
30 }