]> Pileus Git - ~andy/sunrise/blob - app-portage/elogviewer/elogviewer-0.4.0.7-r3.ebuild
app-portage/elogviewer: einfo -> elog
[~andy/sunrise] / app-portage / elogviewer / elogviewer-0.4.0.7-r3.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="Graphical utility to parse the contents of the elogs"
6 HOMEPAGE="http://forums.gentoo.org/viewtopic-p-3374725.html#3374725"
7 SRC_URI="http://www.rz-berlin.mpg.de/~laurin/${P}.tar.bz2"
8
9 LICENSE="GPL-2"
10 SLOT="0"
11 KEYWORDS="~x86"
12 IUSE=""
13
14 DEPEND=""
15 RDEPEND=">=dev-lang/python-2.3
16         >=dev-python/pygtk-2.0
17         >=sys-apps/portage-2.1"
18
19 src_install() {
20         dobin "${WORKDIR}"/elogviewer
21         dodoc "${WORKDIR}"/CHANGELOG
22         doman "${FILESDIR}"/elogviewer.1
23 }
24
25 pkg_postinst() {
26         elog
27         elog "In order to use this software, you need to activate"
28         elog "Portage's ELOG features.  Required is"
29         elog "       PORTAGE_ELOG_SYSTEM=\"save\" "
30         elog "and at least one out of "
31         elog "       PORTAGE_ELOG_CLASSES=\"warn error info log\""
32         elog "More information on the ELOG system can be found"
33         elog "in /etc/make.conf.example"
34         elog
35         elog "To operate properly this software needs the directory"
36         elog "$PORT_LOGDIR/elog created, belonging to group portage."
37         elog "To start the software as a user, add yourself to the portage"
38         elog "group."
39         elog
40 }