]> Pileus Git - ~andy/sunrise/blob - app-office/wiipresent/wiipresent-0.7.5.2.ebuild
fix changelogs
[~andy/sunrise] / app-office / wiipresent / wiipresent-0.7.5.2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils toolchain-funcs
8
9 DESCRIPTION="Small program that enables you to use a Nintendo Wiimote for giving presentations"
10 HOMEPAGE="http://dag.wieers.com/home-made/wiipresent/"
11 SRC_URI="http://dag.wieers.com/home-made/${PN}/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS=""
16 IUSE=""
17
18 RDEPEND="=dev-libs/libwiimote-9999*"
19 DEPEND="${RDEPEND}"
20
21 src_prepare() {
22         epatch \
23                 "${FILESDIR}"/${PV}-include.patch \
24                 "${FILESDIR}"/${PV}-LDFLAGS.patch
25 }
26
27 src_compile() {
28         emake \
29                 CC=$(tc-getCC) \
30                 CFLAGS="${CFLAGS}" || \
31                 die "compilation failed"
32 }
33
34 src_install() {
35         emake DESTDIR="${D}" install || die "installation failed"
36         dodoc AUTHORS ChangeLog README TODO || die "nothing to read"
37 }