]> Pileus Git - ~andy/sunrise/blob - app-office/thinking-rock-bin/thinking-rock-bin-2.0_pre2-r2.ebuild
app-dicts/words-bin: Adding ~amd64 keyword
[~andy/sunrise] / app-office / thinking-rock-bin / thinking-rock-bin-2.0_pre2-r2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 MY_P="tr-2.0.epsilon"
8 DESCRIPTION="Java-based Getting Things Done (GTD) application"
9 HOMEPAGE="http://thinkingrock.com.au/"
10 SRC_URI="mirror://sourceforge/thinkingrock/${MY_P}.zip"
11
12 LICENSE="CDDL"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 RDEPEND=">=virtual/jre-1.5.0"
18 DEPEND="${DEPEND}
19         app-arch/unzip"
20
21 S=${WORKDIR}/${MY_P}
22
23 src_install() {
24         local installDir=/opt/${MY_P}
25
26         insinto /opt
27         doins -r "${S}"
28         fperms a+rx ${installDir}/bin/thinkingrock ${installDir}/bin/xdg-email ${installDir}/bin/xdg-open
29         # Symlink the wrapper script
30         dosym ${installDir}/bin/thinkingrock /usr/bin/thinkingrock
31         # Symlink the directory and the jar to have them without version number
32         dosym ${installDir} /opt/${PN}
33
34         newicon thinkingrock/resource/images/logo.png thinking-rock.png
35         newmenu "${FILESDIR}"/thinking-rock-2.0.desktop thinking-rock.desktop
36 }