]> Pileus Git - ~andy/sunrise/blob - app-office/homebank/homebank-3.3.ebuild
733b47dd694aa71019e0f71efe5e27cf9e5d7e9b
[~andy/sunrise] / app-office / homebank / homebank-3.3.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 KEYWORDS="~amd64 ~x86"
8
9 MY_P=${P}_unstable
10
11 DESCRIPTION="The free software you have always wanted to manage your personal accounts at home"
12 HOMEPAGE="http://homebank.free.fr/index.php"
13 SRC_URI="http://homebank.free.fr/public/${MY_P}.tar.gz"
14 LICENSE="GPL-2"
15 SLOT="0"
16 IUSE="ofx"
17
18 RDEPEND=">=x11-libs/gtk+-2.0
19         ofx? ( >=dev-libs/libofx-0.7 )"
20 DEPEND="${REPEND}
21         dev-util/pkgconfig"
22
23 S=${WORKDIR}/${MY_P}
24
25 src_unpack() {
26         unpack ${A}
27         epatch "${FILESDIR}/${P}-libofx.patch"
28 }
29
30 src_compile() {
31         econf \
32                 $(use_with ofx)
33         emake || die "emake failed"
34 }
35
36 src_install() {
37         emake DESTDIR="${D}" install || die "emake install failed"
38         dodoc AUTHORS ChangeLog NEWS README
39 }