]> Pileus Git - ~andy/sunrise/blob - app-office/homebank/homebank-3.3.ebuild
app-office/homebank: reordered variables
[~andy/sunrise] / app-office / homebank / homebank-3.3.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 MY_P=${P}_unstable
8
9 DESCRIPTION="The free software you have always wanted to manage your personal accounts at home"
10 HOMEPAGE="http://homebank.free.fr/index.php"
11 SRC_URI="http://homebank.free.fr/public/${MY_P}.tar.gz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 IUSE="ofx"
15 KEYWORDS="~amd64 ~x86"
16
17 RDEPEND=">=x11-libs/gtk+-2.0
18         ofx? ( >=dev-libs/libofx-0.7 )"
19 DEPEND="${REPEND}
20         dev-util/pkgconfig"
21
22 S=${WORKDIR}/${MY_P}
23
24 src_unpack() {
25         unpack ${A}
26         epatch "${FILESDIR}/${P}-libofx.patch"
27 }
28
29 src_compile() {
30         econf \
31                 $(use_with ofx)
32         emake || die "emake failed"
33 }
34
35 src_install() {
36         emake DESTDIR="${D}" install || die "emake install failed"
37         dodoc AUTHORS ChangeLog NEWS README
38 }