]> Pileus Git - ~andy/sunrise/blob - app-office/ganttproject-bin/ganttproject-bin-2.0.10.ebuild
dev-db/cppdb: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / app-office / ganttproject-bin / ganttproject-bin-2.0.10.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils java-pkg-2
6
7 MY_P=${PN/-bin}-${PV}
8 DESCRIPTION="A tool for creating a project schedule by means of Gantt chart and resource load chart"
9 HOMEPAGE="http://ganttproject.sourceforge.net/"
10 SRC_URI="http://ganttproject.googlecode.com/files/${MY_P}.zip"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 DEPEND="app-arch/unzip
18         >=virtual/jdk-1.4"
19 RDEPEND="virtual/jre"
20
21 S="${WORKDIR}/${MY_P}"
22
23 src_install() {
24         insinto /usr/share/${PN}
25         doins -r eclipsito.jar plugins/ || die
26
27         newbin "${FILESDIR}/${PV%.*}-${PN}" ${PN} || die
28
29         insinto /usr/share/${PN}/examples
30         doins *.gan || die
31
32         doicon "${S}/plugins/net.sourceforge.ganttproject_${PV%.*}.0/data/resources/icons/ganttproject.png"
33         make_desktop_entry ${PN} "GanttProject" ${PN/-bin} "Java;Office;ProjectManagement"
34 }