]> Pileus Git - ~andy/sunrise/blob - app-mobilephone/series60-remote/series60-remote-0.4.80.ebuild
x11-themes/gtk-themes-h2o-gtk2: Add ~amd64 keyword
[~andy/sunrise] / app-mobilephone / series60-remote / series60-remote-0.4.80.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6 PYTHON_DEPEND="2"
7 SUPPORT_PYTHON_ABIS="1"
8
9 inherit distutils eutils
10
11 DESCRIPTION="A Python application to manage your S60 3rd/5th Edition mobile phone"
12 HOMEPAGE="http://series60-remote.sourceforge.net/"
13 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="stats obex"
19
20 RDEPEND="obex? ( app-mobilephone/obexftp[python] )
21         stats? ( dev-python/matplotlib )
22         dev-python/pybluez
23         dev-python/PyQt4[sql,webkit]"
24
25 RESTRICT_PYTHON_ABIS="3.*"
26
27 DOCS="TODO Changelog"
28
29 src_prepare() {
30         epatch "${FILESDIR}/${PN}-menufix.patch"
31         distutils_src_prepare
32 }
33
34 src_compile() {
35         { :; }
36 }