]> Pileus Git - ~andy/sunrise/blob - app-mobilephone/openmoko-dfu-util/openmoko-dfu-util-9999.ebuild
app-mobilephone/openmoko-dfu-util: correct leading spaces, watch your repoman output
[~andy/sunrise] / app-mobilephone / openmoko-dfu-util / openmoko-dfu-util-9999.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit subversion autotools
6
7 DESCRIPTION="Implements the Host (PC) side of the USB DFU (Universal Serial Bus Device Firmware Upgrade) protocol."
8 HOMEPAGE="http://wiki.openmoko.org/wiki/Dfu-util/"
9 ESVN_REPO_URI="http://svn.openmoko.org/trunk/src/host/dfu-util/"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="dev-libs/libusb"
17 RDEPEND="${DEPEND}"
18
19 src_compile() {
20         eautoreconf || die "eautoreconf failed"
21         econf prefix=/usr || die "Configure failed"
22         emake || die "Make failed"
23 }
24
25 src_install() {
26         emake DESTDIR="${D}" install || die "Make install failed"
27 }