]> Pileus Git - ~andy/sunrise/blob - app-misc/zgsmplay/zgsmplay-1.4.ebuild
net-misc/geomyidae: removed from sunrise, cause it is in main tree now
[~andy/sunrise] / app-misc / zgsmplay / zgsmplay-1.4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils toolchain-funcs
6
7 DESCRIPTION="Curses-based real-time GSM file player with file selector"
8 HOMEPAGE="http://www.svgalib.org/rus/zgsmplay.html"
9 SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/apps/sound/players/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="sys-libs/ncurses"
17 RDEPEND="${DEPEND}"
18
19 src_unpack() {
20         unpack ${A}
21         cd "${S}"
22         epatch "${FILESDIR}"/${P}-makefile.patch
23 }
24
25 src_compile() {
26         emake \
27                 CC=$(tc-getCC) \
28                 AR=$(tc-getAR) \
29                 RANLIB=$(tc-getRANLIB) \
30                 OPTOPT="${CFLAGS}" \
31                 all || die "emake failed"
32 }
33
34 src_install() {
35         emake DESTDIR="${D}" install || die "emake install failed"
36         dodoc ChangeLog NEWS README TODO
37 }