]> Pileus Git - ~andy/sunrise/blob - app-misc/youtranslate/youtranslate-1.1.10.ebuild
dev-db/sql2class: Adding ~amd64 keyword
[~andy/sunrise] / app-misc / youtranslate / youtranslate-1.1.10.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit mono eutils
6
7 DESCRIPTION="Gtk# frontend for Internet translation services"
8 HOMEPAGE="http://www.laas02.org/?page_id=17"
9 SRC_URI="http://www.laas02.org/wp-content/res/yt/${P}_src.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND=">=dev-lang/mono-1.0
17         >=dev-dotnet/gtk-sharp-2.4
18         >=dev-dotnet/glade-sharp-2.4"
19 RDEPEND="${DEPEND}"
20
21 src_unpack() {
22         unpack ${A}
23         cd "${S}"
24         epatch "${FILESDIR}/${P}-makefile-depend-bump.patch"
25 }
26
27 src_compile() {
28         emake -f Makefile.solution.youtranslate || die "emake failed"
29 }
30
31 src_install() {
32         dobin youtranslate.exe "${FILESDIR}/youtranslate"
33         doicon yTicon.png
34         make_desktop_entry "${PN}" "YouTranslate!" yTicon.png "Office;Dictionary"
35 }