]> Pileus Git - ~andy/sunrise/blob - app-misc/ssid/ssid-0.1.ebuild
net-misc/geomyidae: removed from sunrise, cause it is in main tree now
[~andy/sunrise] / app-misc / ssid / ssid-0.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit toolchain-funcs
6
7 DESCRIPTION="Simple setsid replacement"
8 HOMEPAGE="http://tools.suckless.org/ssid"
9 SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
10
11 LICENSE="MIT"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 src_unpack() {
17         unpack ${A}
18         cd "${S}"
19
20         sed -i \
21                 -e "/strip/d" \
22                 Makefile || die "sed failed"
23
24         sed -i \
25                 -e "s/^CFLAGS = -Os/CFLAGS +=/" \
26                 -e "s/^LDFLAGS =/LDFLAGS +=/" \
27                 -e "/^CC/d" \
28                 config.mk || die "sed failed"
29 }
30
31 src_compile() {
32         tc-export CC
33         emake || die "emake failed"
34 }
35
36 src_install() {
37         emake DESTDIR="${D}" PREFIX=/usr install || die "emake install failed"
38
39         dodoc README || die "dodoc failed"
40 }