]> Pileus Git - ~andy/sunrise/blob - app-misc/ssid/ssid-0.1.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update header
[~andy/sunrise] / app-misc / ssid / ssid-0.1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit toolchain-funcs
6
7 DESCRIPTION="simple setsid replacement"
8 HOMEPAGE="http://tools.suckless.org/view/other+tools"
9 SRC_URI="http://suckless.org/download/${P}.tar.gz"
10
11 LICENSE="MIT"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 DEPEND=""
17 RDEPEND=""
18
19 src_unpack() {
20         unpack ${A}
21         cd "${S}"
22
23         sed -i \
24                 -e "s/.*strip.*//" \
25                 Makefile || die "sed failed"
26
27         sed -i \
28                 -e "s/CFLAGS = -Os/CFLAGS +=/" \
29                 -e "s/LDFLAGS =/LDFLAGS +=/" \
30                 config.mk || die "sed failed"
31 }
32
33 src_compile() {
34         emake CC=$(tc-getCC) || die "emake failed"
35 }
36
37 src_install() {
38         emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
39
40         dodoc README
41 }