]> Pileus Git - ~andy/sunrise/blob - app-misc/qbrew/qbrew-0.4.1.ebuild
app-misc/qbrew: Remove depreciated qt4 eclass functions and fix for qt split ebuilds...
[~andy/sunrise] / app-misc / qbrew / qbrew-0.4.1.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="1"
6 inherit qt4 multilib
7
8 DESCRIPTION="Homebrewer's recipe calculator"
9 HOMEPAGE="http://www.usermode.org/code.html"
10 SRC_URI="http://www.usermode.org/code/${P}.tar.gz"
11
12 LICENSE="BSD-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 DEPEND="|| ( ( x11-libs/qt-core:4 x11-libs/qt-gui:4 ) >=x11-libs/qt-4.3:4 )"
18 RDEPEND="${DEPEND}"
19
20 src_compile() {
21         export BINDIR="/usr/bin" DATADIR="/usr/share/${PN}" DOCDIR="/usr/share/doc/${P}"
22         ./configure --qtdir="/usr/$(get_libdir)/qt4" || die "configure failed"
23         echo "QT += xml" >> qbrew.pro
24         eqmake4 || die "qmake failed"
25         emake || die "emake failed"
26 }
27
28 src_install() {
29         dobin qbrew || die "bin install failed"
30         insinto /usr/share/${PN}
31         doins data/* pics/splash.png || die "install failed"
32         dohtml -r docs/* || die "documentation install failed"
33         dodoc AUTHORS ChangeLog README TODO || die "documentation install failed"
34 }