]> Pileus Git - ~andy/sunrise/blob - app-misc/pysdm/pysdm-0.4.1.ebuild
716bb0617dca58c06c9a2407b3766a476709eb53
[~andy/sunrise] / app-misc / pysdm / pysdm-0.4.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit python
6
7 DESCRIPTION="A PyGTK program for editing fstab"
8 HOMEPAGE="http://pysdm.sourceforge.net"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="dev-python/pygtk
17         >=dev-lang/python-2.4"
18 RDEPEND=${DEPEND}
19
20 src_install() {
21         emake DESTDIR="${D}" install || die "emake failed"
22         dodoc NEWS TODO || die
23         newbin ${PN}/pysdm.py pysdm || die "failed to create executable"
24 }
25
26 pkg_postinst() {
27         python_mod_optimize /usr/share/pysdm/fsdata/
28 }
29
30 pkg_postrm() {
31         python_mod_cleanup /usr/share/pysdm/fsdata/
32         python_mod_cleanup
33 }