]> Pileus Git - ~andy/sunrise/blob - app-misc/pycarddav/pycarddav-0.4.ebuild
media-video/ucview: fix metadata.xml
[~andy/sunrise] / app-misc / pycarddav / pycarddav-0.4.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6 SUPPORT_PYTHON_ABIS="1"
7 RESTRICT_PYTHON_ABIS="3.*"
8 PYTHON_DEPEND="2:2.6"
9 PYTHON_USE_WITH="sqlite"
10 DISTUTILS_SRC_TEST="setup.py"
11
12 inherit distutils
13
14 DESCRIPTION="A CardDAV based address book tool"
15 HOMEPAGE="http://lostpackets.de/pycarddav/"
16 SRC_URI="https://lostpackets.de/pycarddav/downloads/${P}.tar.gz"
17
18 LICENSE="MIT"
19 KEYWORDS="~x86 ~amd64"
20 SLOT="0"
21 IUSE=""
22
23 DEPEND="dev-python/lxml
24         dev-python/requests
25         dev-python/setuptools
26         dev-python/urwid
27         dev-python/vobject
28         virtual/python-argparse"
29 RDEPEND="${DEPEND}"
30
31 DOCS="pycard.conf.sample README.rst CHANGELOG NEWS"
32
33 pkg_postinst() {
34         ewarn "Copy and edit the supplied pycard.conf.sample file"
35         ewarn "(default location is ~/.pycard/pycard.conf)."
36         ewarn "Beware that only you can access this file,"
37         ewarn "if you have untrusted users on your machine,"
38         ewarn "since the password is stored in cleartext."
39 }