]> Pileus Git - ~andy/sunrise/blob - app-misc/pcmanfm/pcmanfm-0.2.4.ebuild
Fix Manifests, repoman: app-misc/pcmanfm remove leading whitespace
[~andy/sunrise] / app-misc / pcmanfm / pcmanfm-0.2.4.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="Extremely fast and lightweight tabbed file manager"
6 HOMEPAGE="http://pcmanfm.sourceforge.net/"
7 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
8
9 LICENSE="GPL-2"
10 SLOT="0"
11 KEYWORDS="~amd64 ~x86"
12 IUSE=""
13
14 RDEPEND="virtual/fam
15         x11-libs/cairo
16         >=x11-libs/gtk+-2.8
17         x11-misc/shared-mime-info
18         x11-themes/gnome-icon-theme"
19 DEPEND="${RDEPEND}
20         dev-util/pkgconfig
21         sys-devel/autoconf
22         >=sys-devel/automake-1.9"
23
24 src_install() {
25         emake DESTDIR="${D}" install || die "emake install failed"
26         dodoc AUTHORS TODO
27 }
28
29 pkg_postinst() {
30         if has_version app-admin/fam ; then
31                 einfo "You are using fam as your file alteration monitor,"
32                 einfo "so you must have famd started before running pcmanfm."
33                 einfo
34                 einfo "To add famd to the default runlevel and start it, run:"
35                 einfo
36                 einfo "# rc-update add famd default"
37                 einfo "# /etc/init.d/famd start"
38                 einfo
39                 einfo "It is recommended you use gamin instead of fam."
40         fi
41 }