]> Pileus Git - ~andy/sunrise/blob - app-misc/navit/navit-9999.ebuild
net-misc/freego: Fix qt deps
[~andy/sunrise] / app-misc / navit / navit-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6 inherit autotools subversion
7
8 DESCRIPTION="An open-source car navigation system with a routing engine"
9 HOMEPAGE="http://www.navit-project.org"
10 SRC_URI=""
11
12 LICENSE="LGPL-2"
13 SLOT="0"
14 KEYWORDS=""
15 IUSE="dbus garmin gps gtk nls python sdl speechd svg"
16
17 RDEPEND="dev-libs/glib:2
18         garmin? ( dev-libs/libgarmin )
19         gtk? ( x11-libs/gtk+:2
20                 x11-misc/xkbd )
21         sdl? ( media-libs/libsdl
22                 media-libs/sdl-image
23                 dev-games/cegui
24                 media-libs/quesoglc )
25         python? ( dev-lang/python )
26         dbus? ( sys-apps/dbus )
27         gps? ( sci-geosciences/gpsd )
28         speechd? ( app-accessibility/speech-dispatcher )"
29
30 DEPEND="${RDEPEND}
31         virtual/pkgconfig
32         dev-vcs/cvs
33         svg? ( || ( gnome-base/librsvg media-gfx/imagemagick[png,svg] ) )"
34
35 ESVN_REPO_URI="http://navit.svn.sourceforge.net/svnroot/navit/trunk/navit"
36
37 src_prepare() {
38         autopoint -f || die "autopoint failed"
39         eautoreconf
40 }
41
42 src_configure() {
43
44         local myconf
45
46         if use svg; then
47          if has_version gnome-base/librsvg; then
48            myconf="--with-svg2png-use-rsvg-convert"
49          else
50            myconf="--with-svg2png-use-convert"
51          fi
52         else
53          myconf="--disable-svg2png"
54         fi
55
56         econf $(use_enable garmin) \
57                 $(use_enable gps libgps) \
58                 $(use_enable gtk gui-gtk) \
59                 $(use_enable sdl gui-sdl) \
60                 $(use_enable nls) \
61                 $(use_enable dbus binding-dbus) \
62                 $(use_enable python binding-python) \
63                 $(use_enable speechd speech-speechd) \
64                 --disable-graphics-qt-painter \
65                 --disable-samplemap \
66                 ${myconf}
67 }
68
69 src_install () {
70         emake DESTDIR="${D}" install || die "Install failed"
71         dodoc AUTHORS ChangeLog README || die "dodoc failed"
72 }