]> Pileus Git - ~andy/sunrise/blob - app-misc/navit/navit-9999.ebuild
app-misc/navit: Whitespace
[~andy/sunrise] / app-misc / navit / navit-9999.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="1"
6 inherit autotools subversion
7
8 DESCRIPTION="An open-source car navigation system with a routing engine."
9 HOMEPAGE="http://www.navit-project.org"
10 SRC_URI=""
11
12 LICENSE="LGPL-2"
13 SLOT="0"
14 KEYWORDS=""
15 IUSE="dbus garmin gps gtk nls python sdl speechd"
16
17 RDEPEND="dev-libs/glib:2
18         garmin? ( dev-libs/libgarmin )
19         gtk? ( x11-libs/gtk+:2
20                 x11-misc/xkbd )
21         sdl? ( media-libs/libsdl
22                 media-libs/sdl-image
23                 dev-games/cegui
24                 media-libs/quesoglc )
25         python? ( dev-lang/python )
26         dbus? ( sys-apps/dbus )
27         gps? ( sci-geosciences/gpsd )
28         speechd? ( app-accessibility/speechd )"
29
30 DEPEND="${RDEPEND}
31         dev-util/pkgconfig
32         dev-util/cvs"
33
34 ESVN_REPO_URI="http://navit.svn.sourceforge.net/svnroot/navit/trunk/navit"
35
36 src_unpack() {
37         subversion_src_unpack
38         autopoint -f || die "autopoint failed"
39         eautoreconf
40 }
41
42 src_compile() {
43         econf $(use_enable garmin) \
44                 $(use_enable gps libgps) \
45                 $(use_enable gtk gui-gtk) \
46                 $(use_enable sdl gui-sdl) \
47                 $(use_enable nls) \
48                 $(use_enable dbus binding-dbus) \
49                 $(use_enable python binding-python) \
50                 $(use_enable speechd speech-speechd) \
51                 --disable-graphics-qt-painter \
52                 --disable-samplemap \
53                 --disable-svg2png
54
55         emake || die "Make failed"
56 }
57
58 src_install () {
59         emake DESTDIR="${D}" install || die "Install failed"
60 }