]> Pileus Git - ~andy/sunrise/blob - app-misc/mswinurl_launcher/mswinurl_launcher-1.0.ebuild
app-misc/mswinurl_launcher: New package for bug #283698 - thanks to ssuominen for...
[~andy/sunrise] / app-misc / mswinurl_launcher / mswinurl_launcher-1.0.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.7.0_rc1.ebuild,v 1.1 2009/03/17 01:22:09 omp Exp $
4
5 inherit eutils fdo-mime
6
7 DESCRIPTION="A launcher and desktop association for Microsoft Windows *.URL (text/x-uri) files"
8 HOMEPAGE="http://bugs.launchpad.net/ubuntu/+source/mime-support/+bug/185165/comments/12"
9 SRC_URI="http://launchpadlibrarian.net/20406796/mswinurl_launcher.py"
10
11 LICENSE="Artistic"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="dev-util/desktop-file-utils"
17 RDEPEND="dev-lang/python"
18
19 S=${WORKDIR}
20
21 src_unpack() {
22         cp "${DISTDIR}/${A}" "${S}" || die "could not copy ${A} to ${S}"
23 }
24
25 src_install() {
26         dobin ${PN}.py || die
27         domenu "${FILESDIR}/${PN}.desktop" || die
28 }
29
30 pkg_postinst() {
31         fdo-mime_desktop_database_update
32 }
33
34 pkg_postrm() {
35         fdo-mime_desktop_database_update
36 }