]> Pileus Git - ~andy/sunrise/blob - app-misc/mswinurl_launcher/mswinurl_launcher-1.0.ebuild
app-admin/jailkit: Adding ~amd64 keyword
[~andy/sunrise] / app-misc / mswinurl_launcher / mswinurl_launcher-1.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils fdo-mime
6
7 DESCRIPTION="A launcher and desktop association for Microsoft Windows *.URL (text/x-uri) files"
8 HOMEPAGE="http://bugs.launchpad.net/ubuntu/+source/mime-support/+bug/185165/comments/12"
9 SRC_URI="http://launchpadlibrarian.net/20406796/mswinurl_launcher.py"
10
11 LICENSE="Artistic"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="dev-util/desktop-file-utils"
17 RDEPEND="dev-lang/python"
18
19 src_install() {
20         dobin "${DISTDIR}"/${PN}.py || die
21         domenu "${FILESDIR}/${PN}.desktop" || die
22 }
23
24 pkg_postinst() {
25         fdo-mime_desktop_database_update
26 }
27
28 pkg_postrm() {
29         fdo-mime_desktop_database_update
30 }