]> Pileus Git - ~andy/sunrise/blob - app-misc/japanese-vocabulary/japanese-vocabulary-0.6.ebuild
81aff780e71fc65afab7d1c379bd7a7e3a4f7fd4
[~andy/sunrise] / app-misc / japanese-vocabulary / japanese-vocabulary-0.6.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils qt4 toolchain-funcs
6
7 KEYWORDS="~x86"
8
9 MY_PN=JapaneseVocabulary
10
11 DESCRIPTION="A simple vocabulary program for studying Japanese."
12 HOMEPAGE="http://code.google.com/p/japanese-vocabulary/"
13 SRC_URI="http://${PN}.googlecode.com/files/${MY_PN}-${PV}-src.tar.gz"
14 LICENSE="GPL-2"
15 SLOT="0"
16 IUSE=""
17
18 DEPEND="$(qt4_min_version 4.2)"
19 RDEPEND="${DEPEND}"
20
21 QT4_BUILT_WITH_USE_CHECK="sqlite3"
22 S=${WORKDIR}/${PN}
23
24 src_compile() {
25         eqmake4
26         emake || die "emake failed"
27 }
28
29 src_install() {
30         dobin ${MY_PN}
31         keepdir /usr/share/${PN}
32 }
33
34 pkg_postinst() {
35         elog "To fetch an up-to-date vocabulary file, run:"
36         elog "  emerge --config =${CATEGORY}/${PF}"
37 }
38
39 pkg_config() {
40         cd "${ROOT}usr/share/${PN}"
41         wget "http://japanese-vocabulary.googlecode.com/files/jlpt.vocab"
42         einfo "The vocabulary database is in:"
43         einfo "  /usr/share/${PN}"
44 }
45
46 pkg_postrm() {
47         # do not leave orphaned cruft behind
48         [[ -e ${ROOT}/usr/share/${PN} ]] && rm -rf /usr/share/${PN}
49 }