]> Pileus Git - ~andy/sunrise/blob - app-misc/hardinfo/hardinfo-0.5.1.ebuild
Use pkgconfig virtual.
[~andy/sunrise] / app-misc / hardinfo / hardinfo-0.5.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils flag-o-matic
8
9 DESCRIPTION="A system information and benchmark tool for Linux systems"
10 HOMEPAGE="http://hardinfo.berlios.de/"
11 SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND="
19         net-libs/libsoup
20         x11-libs/gtk+:2"
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig"
23
24 src_prepare() {
25         epatch "${FILESDIR}"/makefile.patch
26 }
27
28 src_configure() {
29         filter-flags "-O*"
30         econf
31 }
32
33 src_compile() {
34         emake -j1
35 }