]> Pileus Git - ~andy/sunrise/blob - app-misc/gpspoint/gpspoint-2.101212.ebuild
dev-libs/qextserialport: Fix qt deps, EAPI bump
[~andy/sunrise] / app-misc / gpspoint / gpspoint-2.101212.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="A utility to transfer tracks, routes and waypoints to and from garmin GPS devices."
8 HOMEPAGE="http://pc12-c714.uibk.ac.at/gpspoint/"
9 SRC_URI="http://pc12-c714.uibk.ac.at/gpspoint/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="dev-util/dialog"
17 RDEPEND="${DEPEND}"
18
19 src_compile() {
20         econf
21         emake -j1 || die "emake failed"
22 }
23
24 src_install() {
25         make DESTDIR="${D}" install || die "installation failed"
26         dodoc AUTHORS NEWS README TODO
27 }
28
29 pkg_postinst() {
30         elog
31         elog "Be sure and set the GPSPORT environment variable in your shell"
32         elog "or in /etc/profile.env if your gps is connected to a serial port"
33         elog "other than /dev/ttyS0 (COM1)."
34         elog "Alternatively you can make a link from /dev/gps to e.g. /dev/ttyS0."
35         elog "gpspoints needs rw access on that device to work properly."
36         elog
37 }