]> Pileus Git - ~andy/sunrise/blob - app-misc/gpspoint/gpspoint-2.030521.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / app-misc / gpspoint / gpspoint-2.030521.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="A utility to transfer tracks, routes and waypoints to and from garmin GPS devices."
8 HOMEPAGE="http://pc12-c714.uibk.ac.at/gpspoint/"
9 SRC_URI="http://pc12-c714.uibk.ac.at/gpspoint/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="dev-util/dialog"
17 RDEPEND="${DEPEND}"
18
19 src_unpack() {
20         unpack ${A}
21         cd "${S}"
22         epatch "${FILESDIR}/${P}-gcc41.patch"
23         epatch "${FILESDIR}/${P}-gcc43.patch"
24 }
25
26 src_compile() {
27         econf
28         emake -j1 || die "emake failed"
29 }
30
31 src_install() {
32         make DESTDIR="${D}" install || die "installation failed"
33         dodoc AUTHORS NEWS README TODO
34 }
35
36 pkg_postinst() {
37         elog
38         elog "Be sure and set the GPSPORT environment variable in your shell"
39         elog "or in /etc/profile.env if your gps is connected to a serial port"
40         elog "other than /dev/ttyS0 (COM1)."
41         elog "Alternatively you can make a link from /dev/gps to e.g. /dev/ttyS0."
42         elog "gpspoints needs rw access on that device to work properly."
43         elog
44 }