]> Pileus Git - ~andy/sunrise/blob - app-misc/genealogyj-bin/genealogyj-bin-2.4.3.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / app-misc / genealogyj-bin / genealogyj-bin-2.4.3.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="GenealogyJ is a viewer and editor for genealogic data and is written in Java"
8 HOMEPAGE="http://genj.sf.net/"
9 SRC_URI="mirror://sourceforge/genj/genj_app-${PV}.zip
10         skins? ( mirror://sourceforge/genj/genj_lnf-2.0.zip )
11         geoview? ( mirror://sourceforge/genj/genj_geo-${PV}.zip )
12         mirror://sourceforge/genj/genj_en-${PV}.zip"
13
14 S=${WORKDIR}
15 LANGS="cs de es fi fr hu nl pl pt_BR ru"
16 for X in ${LANGS} ; do
17         IUSE="${IUSE} linguas_${X}"
18         SRC_URI="${SRC_URI} linguas_${X}? ( mirror://sourceforge/genj/genj_${X}-${PV}.zip )"
19 done
20
21 LICENSE="GPL-2"
22
23 SLOT="0"
24 KEYWORDS="~x86"
25 IUSE="geoview skins"
26
27 DEPEND="app-arch/unzip"
28 RDEPEND=">=virtual/jre-1.4"
29
30 pkg_setup() {
31         if [ -z "${LINGUAS}" ]; then
32                 ewarn " To install a localized version, set the according LINGUAS variable(s)."
33                 ewarn " Default: en (is always installed) "
34                 ewarn " Supported localizations: cs* de es fi* fr hu* nl* pt_BR* pl* ru*"
35                 ewarn " (* = Help file in English only. Upstream doesn't have a translation.) "
36         fi
37 }
38
39 src_compile() {
40         einfo "Binary only installation, no compilation needed."
41 }
42
43 src_install() {
44         PROGRAM_DIR=/opt/${PN}
45
46         insinto ${PROGRAM_DIR}
47         exeinto ${PROGRAM_DIR}
48
49         doins -r *.jar gedcom report help contrib doc lib
50         use skins && doins -r lnf
51         doexe run.sh
52         # Necessary to be able to run it as a user:
53         fperms a+rx ${PROGRAM_DIR}/run.sh
54
55         into /opt
56         dobin "${FILESDIR}/genealogyj"
57 }
58
59 pkg_postinst() {
60         einfo
61         einfo "This ebuild does not install the GenealogyJ web applet"
62         einfo
63 }