]> Pileus Git - ~andy/sunrise/blob - app-misc/fslint/fslint-2.42.ebuild
app-admin/noobjuice-gentoo: Fix qt deps, EAPI bump
[~andy/sunrise] / app-misc / fslint / fslint-2.42.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6 PYTHON_DEPEND="2"
7
8 inherit eutils python
9
10 DESCRIPTION="A utility to find various forms of lint on a filesystem"
11 HOMEPAGE="http://www.pixelbeat.org/fslint/"
12 SRC_URI="http://www.pixelbeat.org/${PN}/${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="nls"
18
19 DEPEND="nls? ( sys-devel/gettext )"
20 RDEPEND="dev-python/pygtk:2"
21
22 src_prepare() {
23         python_convert_shebangs -r 2 .
24         # change some paths to make fslint-gui run when installed in /usr/bin
25         sed -e "s:^liblocation=.*$:liblocation='${EROOT}usr/share/${PN}' #Gentoo:" \
26                 -e "s:^locale_base=.*$:locale_base=None #Gentoo:" \
27                 -i fslint-gui || die "sed failed"
28 }
29
30 src_install() {
31         # the only sane way of installing dozens of files, most (but not all!)
32         # of them executable scripts, spread over multiple subdirectories
33         dodir /usr/share/${PN}
34         cp -R ${PN}/ "${ED}"/usr/share/${PN} || die "cp failed"
35
36         insinto /usr/share/${PN}
37         doins ${PN}{.glade,.gladep,_icon.png} || die "doins failed"
38
39         dobin ${PN}-gui || die "dobin failed"
40
41         doicon ${PN}_icon.png || die "doicon failed"
42         domenu ${PN}.desktop || die "domenu failed"
43
44         dodoc doc/{FAQ,NEWS,README,TODO} || die "dodoc failed"
45         doman man/{fslint.1,fslint-gui.1} || die "doman failed"
46
47         if use nls ; then
48                 cd po
49                 emake DESTDIR="${D}" install || die "locales install failed"
50         fi
51 }