]> Pileus Git - ~andy/sunrise/blob - app-misc/bsc/bsc-4.0.06_beta.ebuild
app-misc/bsc: Drop dependency to Qt4 metapackage
[~andy/sunrise] / app-misc / bsc / bsc-4.0.06_beta.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit eutils qt4-r2 versionator
8
9 MY_PV="$(replace_version_separator 3 '.')"
10 DESCRIPTION="BSCommander is a Qt based file manager"
11 HOMEPAGE="http://www.beesoft.org/index.php?id=bsc"
12 SRC_URI="http://www.beesoft.org/download/${PN}_${MY_PV}_src.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 IUSE=""
17 KEYWORDS="~amd64 ~x86"
18
19 DEPEND="x11-libs/qt-gui:4
20         x11-libs/libX11
21         x11-libs/libXext"
22 RDEPEND="${DEPEND}"
23
24 S=${WORKDIR}/${PN}
25
26 src_prepare() {
27         sed -i -e "/^CXXFLAGS.*/s:-pipe -O4:${CXXFLAGS}:" \
28                 Makefile || die "sed failed on Makefile"
29         sed -i -e "/^QMAKE_CXXFLAGS_RELEASE.*/s:-O4:${CXXFLAGS}:" \
30                 ${PN}.pro || die "sed failed on ${PN}.pro"
31 }
32
33 src_install() {
34         dobin ${PN} || die "dobin failed"
35
36         insinto /usr/share/${PN}
37         # shouldn't it be dohtml?
38         doins help.en.html || die "doins failed"
39
40         newicon BeesoftCommander.png ${PN}.png
41         make_desktop_entry ${PN} BSCommander ${PN} "FileManager;Utility;Qt"
42 }